Instructions how to compile BASIC256 from source on Linux? (Program Bug and Problems)

by cub256, Friday, January 23, 2015, 21:40 (828 days ago)

Hi,

I have downloaded and unpacked basic256-1.1.3.0 from http://sourceforge.net/projects/kidbasic/files/. However neither the usual './configure' nor 'make' work to build it from source on my Ubuntu 14.04 :-( I tried all subdirectories.

Where can I find instructions to compile and build it, please?

Thanks,

cub256

Instructions how to compile BASIC256 from source on Linux?

by otoomet, Sunday, January 25, 2015, 21:14 (826 days ago) @ cub256

look at the file COMPILING.txt

You need qt5 development libraries. I don't know which ones exactly, I installed several, but probably qt-sdk will do the trick.

I compiled but did not install. It runs, but does not show any menus. Will try again in a virtual machine where I also dare to run the install scripts.

Cheers,
Ott

Instructions how to compile BASIC256 from source on Linux?

by cub256, Monday, January 26, 2015, 20:15 (825 days ago) @ otoomet

Thanks Ott,

but I need definitely menus. What a shame that this wonderful program cannot be compiled completely :-( I would like so much to have a fully working advanced BASIC256 with Ubuntu!

Cheers

Siggi

Instructions how to compile BASIC256 from source on Linux?

by otoomet, Friday, January 30, 2015, 23:50 (821 days ago) @ cub256

You can also download 1.1.4.tar.gz from sourceforge (under FILES). It also wants to have libqt5serialport5-dev and libudev-dev installed.

However, still no menus, still not have had time to try in virtual machine.

Would be nice to be able to specify the destination of binaries, something like --prefix=$HOME or something like that...

Solved, with Wine

by cub256, Tuesday, January 27, 2015, 09:52 (824 days ago) @ cub256

I now have BASIC256-1.1.4.0 on my Linux-Ubuntu :-)

1) Wine 1.6.2 on Ubuntu 14.04
2) Configure Wine to Windows Version: Windows XP
3) open the Windows version BASIC256-1.1.4.0_Win32_Install.exe with the wine Program Loader

Well, I did not build, but so what!

Solved, with Wine

by johnno56, Tuesday, June 09, 2015, 01:54 (692 days ago) @ cub256

cub256,

I found a "deb" file for version 1.1.2.3 that runs really well. I had thought of the "wine" solution a while ago, but I prefer to run "native". (less problems)

Anyway, thanks for replying, and thanks for the suggestion. I suppose, if I can wait long enough, someone may create a "deb" for 1.1.4.0... but I won't hold my breath waiting... lol.

Cheers

J

RSS Feed of thread
powered by my little forum