BTK (Sample Programs)

by johnno56, Thursday, June 12, 2014, 23:22 (1112 days ago)

This may be a stupid question. I have seen references to "BTK" in several programs, of which all fail to run, because I am running Basic256 "as is". Can I assume that BTK is an "add-on"-type application that produces GUI's? If so, how can I make use of it? And where can I download it?

J

BTK

by Jim ⌂ @, Russell, KY, Friday, June 13, 2014, 17:13 (1111 days ago) @ johnno56

Hey,

The BTK subroutines were created by UglyMike and you can find his sample code and the routines on his page at http://www.uglymike.net/

BASIC256 was never really intended to create GUI applications but Mike has spent a lot of time coming up with a widget library that works.

Jim

BTK

by johnno56, Saturday, June 14, 2014, 11:00 (1111 days ago) @ Jim

I run with Linux Mint 16.

Using Wine (running with basic256 v 1.1) it runs fine. However, the version that I have on Linux (v 0.9.6.69) it fails with the 'global' commands.

I am going to try and compile v 1.1.26 to run on Linux. No guarantees, as I have not tried this before. I will let you know how it goes... fingers crossed.

J

BTK

by johnno56, Saturday, June 14, 2014, 11:39 (1111 days ago) @ johnno56

Compile failed.

All dependencies ARE installed.

Attempted to build by issuing the 'make clean' command.

john@baldwin-001 ~/Downloads/basic256-1.1.2.6 $ make clean
/usr/lib/x86_64-linux-gnu/qt5/bin/qmake -config debug -o Makefile BASIC256.pro
make: /usr/lib/x86_64-linux-gnu/qt5/bin/qmake: Command not found
make: *** [Makefile] Error 127

qmake IS install

john@baldwin-001 ~/Downloads/basic256-1.1.2.6 $ qmake --version
QMake version 2.01a
Using Qt version 4.8.4 in /usr/lib/i386-linux-gnu

I am going to go out on a limb here and guess that basic256 required QT4 to compile and not QT5 which is installed.

I'm not sure how to get around this problem. I guess I will have to be content with using basic256 v 1.1 via Wine or basic256 v 0.9.6.69 running native on Linux.

My brain hurts. I think I need coffee....

J

BTK

by Jim ⌂ @, Russell, KY, Sunday, June 15, 2014, 02:28 (1110 days ago) @ johnno56

You need to uninstall the qt4 development libraries and install the qt5-dev packages. There is a ppa for ubuntu (ppa:basic256/basic256) or you can Wine the current windows from sourceforge 1.1.2.?

Jim

RSS Feed of thread
powered by my little forum